April 11, 2014 | Posted in secure file transfer, Secure Platform, Security | By

Thru does not use the OpenSSL technology that caused the vulnerability. Your data is safe, and no action is needed on your part.

For those who are interested in knowing more about Heartbleed, we have provided answers to three common questions below.

Who is affected? Any website that uses OpenSSL, an open-source software that is widely used to encrypt web communications. About two-thirds of websites today utilize this technology.

What is at risk? Data stored in sites using OpenSSL could be at risk. This could include sensitive data such as usernames, passwords, and credit card information.

How can I verify Thru’s security or test other sites vulnerability? Check your Thru site using this Heartbleed vulnerability test and entering the full name of your site (i.e. https://YourCompanyName.thruinc.net). You can also test any other website using this tool.

At Thru we take security seriously. If you have any questions please contact us.

Kevin Westenkirchner
Vice President of Support Services and Operations

 

Be the first to comment.

Leave a Reply

*



You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>